
Pre Exam Study Guide: 

Domestic Data Entry Operator (Class X IT) 

-----------------------------------------------------------------------------------------------------------------  

1. Unit 1: Digital Documentation (Advanced) 

Unit 1 of the sources focuses on Digital Documentation (Advanced) using LibreOffice Writer 

(version 6.4) to create professional-style documents. Here are the detailed notes for each 

chapter: 

 

Chapter 1: Introduction to Styles 

A Style is a saved collection of formatting information—such as font size, name, weight, and 

alignment—that can be applied consistently throughout a document. 

• Benefits of Styles: They ensure a consistent format in large reports, reduce the time and effort 

required for formatting, and allow the author to focus on content rather than appearance. 

Writer Style Categories 

Category Description Key Formatting Attributes 

Page 
Defines the layout for all pages 

in a document. 

Page size, margins, header/footer, borders, and 

background. 

Paragraph 
Manages blocks of text separated 

by "Enter." 
Tab stops, alignment, line spacing, and borders. 

Character 
Applies formatting to a block of 

letters/words. 

Text color, size, and highlighting. Note: Does not 

affect the whole paragraph. 

Frame 
Formats containers for text, 

graphics, or lists. 
Size, position, borders, and text wrap settings. 

List 
Specifically for bulleted or 

numbered sequences. 

Numbering styles, bullet types, and numeric 

formats. 

Table Controls the look of data grids. 
Border colors, cell alignment, and background 

patterns. 

 

• Accessing Styles: Use the F11 function key, the Styles menu from the Menu bar, the drop-

down list on the Toolbar, or the Sidebar Menu. 

• Fill Format Mode: A tool used to quickly apply the same style to many scattered areas in a 

document. 

• Creating and Updating Styles: 

    ◦ From Selection: Formatting a portion of text manually and then saving it as a new style. 

    ◦ Drag and Drop: Dragging a formatted text selection into the Styles menu; however, this 

cannot be used to create a Page Style. 

    ◦ Load Styles: Copying styles from an existing template or another document to maintain 

consistency. 

---------------------------------------------------------------------------------------------------------------- 

Chapter 2: Working with Images 

Digital images are representations made of a finite set of values called pixels, usually stored in 

formats like GIF, JPG, PNG, or BMP. 



• Inserting Images: 

    ◦ Insert Image Dialog: Navigating via Insert > Image. 

    ◦ Drag and Drop: Dragging an image from a file browser directly into the document. 

    ◦ Copy and Paste: Using the clipboard to move images from a source to a target document. 

    ◦ Linking: Storing a reference/link to the image instead of embedding it, which reduces the 

file size of the document. 

Inserting Images: Linking vs. Embedding 

o Embedding (Default): The image is saved inside the .odt file. The document 

is self-contained but larger in size. 

o Linking: The document only stores a reference to the image on your disk. 

▪ Procedure: Select Insert > Image, choose the file, and check the Link 

box. This keeps the file size small and allows the image to update if the 

source file is edited. 

 

• Modifying Images (Image Toolbar): 

    ◦ Filters: There are 11 filters, including Invert (inverts color values), Smooth (softens 

contrast), Aging (simulates time effects), and Charcoal Sketch. 

Categorized Image Filters (11 Total): 

Artistic Effects: Charcoal Sketch, Relief (creates shadows), Mosaic (joins pixels into color 

areas), Posterize (reduces colors like a painting), Aging (simulates time). 

Adjustments: Invert (reverses color values), Smooth (softens contrast), Sharpen (increases 

contrast), Remove Noise (cleans single pixels), Solarization (reverses tones). 

    ◦ Crop: Cutting off non-desirable edges of an image. 

    ◦ Resizing: Enlarging or reducing the image size; dragging corner handles changes both 

width and height simultaneously. 

• Drawing Objects: Writer provides a Drawing Toolbar to create designs like flowcharts, 

callout boxes, and shapes. 

• Grouping: Allows multiple overlapping shapes to be treated as a single entity, meaning a 

change applied to the group affects all members. 

• Positioning Settings: 

    ◦ Arrangement: Determines the layering of overlapping objects (e.g., Bring to Front, Send 

to Back). 

    ◦ Anchoring: Acts as a reference point (Page, Paragraph, Character, or Frame). 

    ◦ Text Wrapping: Controls how text flows around the image (e.g., Page Wrap flows text 

around all sides; Wrap Through superimposes the image on the text). 

---------------------------------------------------------------------------------------------------------------- 

Chapter 3: Advanced Features of Writer 

This chapter covers tools for organizing and reviewing professional documents. 

• Table of Contents (ToC): 

    ◦ Automated list of topics and page numbers based on a Hierarchy of Headings (up to 10 

levels, H1 to H10). 

    ◦ Entries are hyperlinked, allowing users to navigate directly to a topic using Ctrl+Click. 

    ◦ ToC is typically protected against accidental manual changes unless specifically 

unchecked. 

• Templates: 

    ◦ Preset layouts that help create professional/formal documents like resumes or project 

reports easily. 

    ◦ Templates in Writer are saved with the .ott extension. 



    ◦ If no specific template is chosen, Writer uses a default blank document template. 

• Track Changes: 

    ◦ A tool used when multiple users review a single document to record every edit made. 

    ◦ Recording: Any addition is displayed in a different color, and deletions appear in strike-

through style. 

    ◦ Managing: The original author can Accept or Reject individual or all changes. 

    ◦ Comments: Reviewers can add notes or suggestions to the document. 

    ◦ Compare Documents: Allows a user to compare an edited version with the original 

document to identify differences 

---------------------------------------------------------------------------------------------------------------  

2. Unit 2: Electronic Spreadsheet (Advanced) 

Unit 2 of the sources covers advanced features of LibreOffice Calc, focusing on data analysis, 

task automation, and collaborative workflows. 

 

Chapter 4: Analyse Data using Scenarios and Goal Seek 

This chapter details tools used to manipulate and interpret data to identify patterns and 

relationships. 

• Data Consolidation: This function combines information from multiple sheets into one 

summary place for comparison. For it to work, data types and labels across sheets must match. 

If the "Link to source data" option is checked, the target sheet updates automatically when 

source data changes. 

• Subtotals: This tool automatically groups data and applies functions like Sum or Average. 

It creates an outline on the left of the row numbers, allowing users to collapse (-) or expand (+) 

different levels of data. 

• What-if Scenarios: A scenario is a set of values used for calculations to explore alternatives 

based on changing conditions. It helps predict outputs and choose the best plan of action. 

• Multiple Operations (What-if Analysis): This planning tool creates a formula array to 

display a list of results based on alternative input values. 

• Goal Seek: This is a "backward calculation" tool. It finds the required input value needed 

to achieve a specific, desired target output. 

Chapter 5: Using Macros in Spreadsheet 

Macros are used to automate repeated tasks such as specific formatting or repetitive formulas. 

• Recording Macros: Macro recording is disabled by default and must be enabled through 

Tools > Options > LibreOffice > Advanced. It records keystrokes and clicks but does not 

record window switching or actions unrelated to spreadsheet content. 

• Naming Rules: Macro names must begin with a letter and cannot contain spaces or special 

characters except for the underscore (_). 

• Structure: Macros are stored in Modules, which are grouped into Libraries. The instructions 

are written in a programming language called BASIC. 

• Macro as a Function: These can be created to perform repetitive calculations that are not 

predefined in Calc. They can accept arguments, perform calculations, and return a result to a 

cell. 

----------------------------------------------------------------------------------------------------------- 

Chapter 6: Linking Spreadsheet Data 

Linking prevents errors from retyping and ensures data remains "live" across different 

locations. 



• Referencing Other Sheets: To refer to a cell in a different sheet within the same file, the 

syntax is $'Sheet Name'.CellAddress. Single quotes are required if the sheet name has 

spaces. 

• Referencing Other Documents: To link to a different file, the syntax includes the file path 

followed by #$, the sheet name, and the cell address. 

• Hyperlinks: 

    ◦ Absolute Hyperlink: Stores the complete path; the link breaks if the file is moved. 

    ◦ Relative Hyperlink: Stores the location relative to the current file, making it more 

flexible if folders are moved together. 

• External Data: Users can insert tables from HTML web pages into Calc using the "Link to 

External Data" dialog. 

• Registered Data Sources: Calc can link to databases (such as .odb files) by registering them 

through Tools > Options > LibreOffice Base > Databases. 

----------------------------------------------------------------------------------------------------------- 

Chapter 7: Share and Review a Spreadsheet 

Sharing allows multiple users to access and edit the same document simultaneously. 

• Shared Mode: When enabled via Tools > Share Spreadsheet, the title bar displays (shared). 

Some features, like Undo and Paste, become unavailable in this mode. 

• Recording Changes: To track edits, users must first disable shared mode and then enable 

Edit > Track Changes > Record. Changed cells are marked with a colored border (usually 

red), and hovering over them shows the author and time of the edit. 

• Comments: Reviewers can add notes via Edit > Track Changes > Comment or Insert > 

Comment. 

• Reviewing: The original author can use the "Manage Changes" dialog to Accept or Reject 

edits. 

• Merging and Comparing: If different users have different versions of a file, they can be 

combined using "Merge Document" or evaluated side-by-side using "Compare Document" 

---------------------------------------------------------------------------------------------------------------- 

Unit 3: Database Management System using LibreOffice Base 

Unit 3 cover the fundamental concepts, operations, and advanced features required for 

managing databases effectively. 

Chapter 8: Introduction to Database Management System 

This chapter introduces the core concepts of data management and the software used to handle 

it. 

• Data and Information: Data consists of raw facts (numbers, text, images), while 

Information is the processed, organized, and meaningful form of that data (e.g., a report card). 

• DBMS Definition: A Database Management System is software used to create, update, and 

retrieve data stored in an organized manner. Examples include MS Access, MySQL, and 

LibreOffice Base. 

• Advantages of DBMS: 

    ◦ Organized Storage: Facilitates fast and accurate retrieval. 

    ◦ Reduced Redundancy and Inconsistency: Minimizes the repetition of data and ensures 

that changes are reflected across all related records. 

    ◦ Data Security: Provides unauthorized access control through encryption and passwords. 

• Data Models: 

    ◦ Hierarchical: Data organized in a tree-like structure. 

    ◦ Network: Multiple records linked to a master file (inverted tree). 



    ◦ Relational: The most common model, where data is stored in tables related through 

common fields. 

• Relational Terminology: 

    ◦ Entity: A real-world object (e.g., a Student). 

    ◦ Attribute/Field: Individual characteristics represented as columns. 

    ◦ Record/Row: The collection of data values for all fields related to one object. 

• Database Keys: 

    ◦ Primary Key: Uniquely identifies a row; it cannot be blank or duplicated. 

    ◦ Foreign Key: A field used to link two tables together. 

    ◦ Candidate and Alternate Keys: All fields eligible to be a primary key are candidate keys; 

those not chosen are alternate keys. 

-----------------------------------------------------------------------------------------------------------  

Chapter 9: Starting with LibreOffice Base 

This chapter covers the technical environment of Base and the creation of its basic unit: the 

table. 

• Data Types: Every field must have a defined type. 

    ◦ Text: VARCHAR (variable length), CHAR (fixed length), and LONGVARCHAR (Memo for long 

descriptions). 

    ◦ Numeric: Includes TINYINT, INTEGER, DECIMAL, and FLOAT for arithmetic calculations. 

    ◦ Others: Boolean (Yes/No), Date/Time, and Binary (for images and sounds). 

• Interface: Base files use the .odb extension. The interface includes the Database Pane 

(listing Tables, Forms, Queries, and Reports) and the Tasks Pane. 

• Creating Tables: 

    ◦ Wizard: Uses pre-designed samples (like "Customer") to quickly select fields. 

    ◦ Design View: Offers more flexibility. Users define Field Names, Field Types, and 

Descriptions. 

• Operations: 

    ◦ Data Entry: Done in Datasheet View; users navigate via the Navigation Box at the bottom 

of the screen. 

    ◦ Sorting: Arranging records in ascending or descending order based on one or more fields. 

---------------------------------------------------------------------------------------------------------------- 

Chapter 10: Working with Multiple Tables 

This chapter focuses on maintaining data integrity across different tables. 

• Editing and Deleting: Tables can be edited in Design View to add or remove fields, or 

renamed/deleted via the right-click pop-up menu. 

• Relationships: Relationships link tables using common fields that must have the same data 

type. 

• Relationship Types: 

    ◦ One-to-One: One record in the master table relates to exactly one in the transaction table. 

    ◦ One-to-Many: The most common; one master record relates to multiple transaction records 

(e.g., one teacher to many students). 

    ◦ Many-to-Many: Multiple records in both tables relate to each other. 

• Referential Integrity: A set of rules ensuring no "unmatched" foreign keys exist. Options 

include: 

    ◦ No Action: Prevents deletion/updates if related records exist. 

    ◦ Update Cascade: Automatically updates/deletes related records. 

    ◦ Set NULL/Default: Assigns a null or default value to related fields if the master is changed. 

-----------------------------------------------------------------------------------------------------------  

Chapter 11: Queries in Base 

Queries are used to filter and retrieve specific information from the database. 

• Definition: A query is a "question" asked of the database to retrieve specific filtered records. 



• Creation Methods: Can be created using a Wizard or Design View. 

• Design View Components: 

    ◦ Tables Pane: Where tables are added for the query. 

    ◦ Design Grid: Used to select fields, set Aliases (readable column names), and apply 

Sorting. 

    ◦ Criterion Row: Used to set search conditions using relational operators (e.g., >, <, =) to 

filter records. 

• Numerical Functions: Queries can perform calculations such as Sum, Average, Min, Max, 

and Count. 

----------------------------------------------------------------------------------------------------------------  

Chapter 12: Forms and Reports 

These objects provide a user-friendly way to interact with and present data. 

• Forms: 

    ◦ Purpose: A user-friendly "front end" for easy data entry and modification. 

    ◦ Components: Consist of Field Controls (a Label and a Text Box). 

    ◦ Modification: Users can change background colors, add Tooltips (help text), or add 

Calendars to date fields for easier entry. 

• Reports: 

    ◦ Purpose: Presents retrieved data (from tables or queries) in an attractive, formatted, and 

customized layout. 

    ◦ Wizard Steps: Includes selecting fields, labeling, Grouping data (e.g., category-wise), and 

selecting layouts (like Tabular). 

    ◦ Dynamic vs. Static: Dynamic reports update automatically when the base data changes; 

Static reports do not. 

    ◦ Report Builder: Used to further customize reports by adding titles, images, and Date/Time 

stamps 

LibreOffice Base Data Types 

As a Data Entry Operator, choosing the correct data type is vital for accuracy and saving 

memory. 

Data Type 

Group 
Specific Type Signed/Unsigned Description/Range 

Numeric TINYINT No 0 to 255 

Numeric SMALLINT Yes -32,768 to 32,767 

Numeric INTEGER Yes -2.14 x 10⁹ to 2.14 x 10⁹ 

Numeric BIGINT Yes -9.22 x 10¹⁸ to 9.22 x 10¹⁸ 

Numeric DECIMAL Yes Unlimited precision for currency/math 

Text CHAR N/A Fixed length (e.g., Passport Number) 

Text VARCHAR N/A Variable length (e.g., Name/Address) 

Date/Time DATE / TIME N/A 
Year/Month/Day or 

Hour/Minute/Second 

Binary 
IMAGE / 

BINARY 
N/A Stores photos, sounds, or digitized data 

 

 



4. Unit 4: Maintain Healthy, Safe, and Secure Working Environment 

Unit 4 focuses on the concept of the working environment in the IT industry, emphasizing safe 

work practices, health problems caused by poor habits, and managing accidents and medical 

emergencies. 

Chapter 13: Health, Safety, and Security at Workplace 

Creating a safe workplace is a collective responsibility that improves both the environment and 

productivity. 

• Core Definitions: 

    ◦ Health: The state of an employee's physical, mental, and social well-being. Organizations 

must provide clean air, filtered water, fresh food, and clean washrooms to maintain this. 

    ◦ Safety: A work environment free from hazards (something that can cause harm) and risks 

(the probability of that harm occurring). 

    ◦ Security: Freedom from potential harm, ensuring the safety of personnel, computer 

systems, and equipment. 

• Health and Safety Policy: A written statement of an employer's commitment to protecting 

workers. It helps identify hazards and outlines accountability for every person in the company. 

Table: Common Workplace Safety Hazards  
Hazard Category Specific Causes and Examples Potential Impact on Health & 

Safety 

Physical Hazards Wet floors, loose wires, uneven 

surfaces, faulty ladders, and 

improperly piled goods. 

Falls, slips, and trips resulting in 

anything from simple bruises to 

serious fractures. 

Electrical Hazards Exposed or worn-out wiring, 

overloaded outlets, faulty 

equipment, and water near 

electronics. 

Electric shock or electrocution, 

which can cause permanent or life-

threatening injuries. 

Fire Hazards Damaged extension cords, 

overloaded circuits, and improper 

storage of flammable or combustible 

materials. 

Damage to the building and 

equipment, as well as severe injuries 

to employees. 

Ergonomic 

Hazards 

Poor sitting posture, working for 

excessive durations in one position, 

and repetitive movements like 

typing. 

Muscle fatigue, back/neck pain, and 

Occupational Overuse Syndrome 

(RSI) like Carpal Tunnel Syndrome. 

Visual Hazards Glare from screens, flickering 

images, and bright light sources 

located directly behind or in front of 

monitors. 

Eye strain, dry eyes, headaches, 

blurry vision, and Computer Vision 

Syndrome. 

Operational 

Hazards 

Improperly handling sharp-edged 

office equipment or lifting heavy 

items without correct posture. 

Cuts, muscle strain, and various 

physical injuries. 

Environmental & 

Psychological 

Poor ventilation, inadequate 

lighting, long working hours, and 

aggressive conflicts with colleagues. 

Stress disorders, lack of 

concentration, dizziness, and 

becoming easily "burned out" 

 

---------------------------------------------------------------------------------------------------------------- 

Chapter 14: Workplace Quality Measures 

This chapter details environmental monitoring and the science of ergonomics—arranging 

things for easy and safe use. 

• Quality Monitoring: Air and water pollution are analyzed via physical, chemical, and 

biological methods. 

• Early Warning Signs & Ergonomic Solutions: 



    ◦ Sore Lower Back: Often caused by lack of lumbar support; use a backrest or pillow. 

    ◦ Stiff Neck: Caused by tilting the head; raise the monitor to eye level. 

    ◦ Arching Wrists: Caused by extended wrists; add a wrist rest and keep elbows at 100–110 

degrees. 

    ◦ Eye Strain: Caused by glares; use anti-glare glasses and follow the 30-30-30 rule (look 30 

meters away for 30 seconds every 30 minutes). 

• Occupational Overuse Syndrome (RSI): Persistent pain in muscles or tendons due to 

repetitive movement, such as Carpal Tunnel Syndrome (pain/numbness in the hand). 

• Hardware Safety: Remove rings, watches, and necklaces before working on internal 

computer components to prevent damage from static electricity. 

-------------------------------------------------------------------------------- -------------------------------- 

Chapter 15: Prevent Accidents and Emergencies 

• Definitions: An accident is an unplanned, unforeseen event resulting in injury; an emergency 

is a crisis situation requiring immediate action. 

• Fire Safety: Workplace fires are often caused by improper storage of flammable materials or 

electrical issues. 

 

Table: Fire Classifications and Extinguisher  

Class Materials Proper Extinguisher 

Class A Wood, Paper, Cloth Water, ABC Powder 

Class B Liquids, Grease, Gas CO2, Foam, ABC Powder 

Class C Electrical Equipment CO2, ABC Powder (Never Water!) 

Class D Volatile Metals (Magnesium) Special ABC Powder 

| 

• Evacuation Procedures: Leave immediately via the nearest emergency exit; use stairs 

instead of elevators (to avoid getting trapped during power failure); and meet at the emergency 

assembly area. 

• Electrical Rescue Techniques: 

    1. Call 108 immediately. 

    2. Do not touch the victim if they are still in contact with a live wire. 

    3. Switch off the power or use a non-conductive material (like wood) to move the victim. 

    4. A victim may require CPR (Cardio-Pulmonary Resuscitation) if they have stopped 

breathing 

----------------------------------------------------------------------------------------------------------------

Essential Exam Comparison Table 

Category Concept A Concept B Key Difference 

Spreadsheets Goal Seek Scenarios Goal Seek finds the input for a specific target; 

Scenarios test multiple inputs to see different 

results. 

Spreadsheets Absolute 

Link 

Relative 

Link 

Absolute is the full path (breaks if file moves); 

Relative is based on current location (stays 

intact). 

Databases Primary 

Key 

Foreign 

Key 

Primary uniquely identifies a record in its own 

table; Foreign links a record to another table. 

Databases Forms Reports Forms are for easy data entry (Input); Reports 

are for professional presentation (Output). 

Safety Hazard Risk Hazard is the dangerous object; Risk is the 

probability of it causing harm. 
 


